Unable to login to Authoring Tool


#1

Hi,

I’ve downloaded the eLearning Authoring Tool, installed it, but I cannot login. All I see is the spinner, then the message “Unable to connect to server”.

Authoring Tool version: 2.0.171
Windows version: Windows 10 Pro, OS Build: 19043.1526, Windows Feature Experience Pack 120.2212.4170.0; latest updates installed

Firewalls are not the problem. I tracked the problem down to Authoring Tool trying to connect with TLS1.0, and the server immediately rejecting the connection attempt. Connecting with TLS1.2 would work. So how do I get the Authoring Tool to use TLS1.2 for the connection?

For the technical inclined: I ran a TCP/IP packet capture program (Wireshark) and see the Authoring Tool establishing a connection to IP address 104.40.64.235 on port 443, then the Tool sends the TLS Client Hello handshake, and the server answers by RST the TCP connection. I.e., even before my credentials are sent, the server resets the connection. Then I tried connecting with openssl s_client and discovered the problem of TLS1.0 vs. TLS 1.2